Блог старого компьютера

Блог старого компьютера


Главная Joomla Joomla не показывает настройки модулей...

Joomla не показывает настройки модулей...

25.01.2012 07:00 Администратор Joomla
Печать PDF
В продолжении предыдущей статьи продолжу разговор об ошибках глюках.... Представим - вы создавали сайт на денвере и загрузив сайт на хостинг обнаруживаете странную картинку: при входе в настрйоки любого модуля они практически не показываются, а если и показываются то на белом фоне и не полностью. Далее рассмотрим причину...

Пример как это выглядит:

error_unicode

А открыв исходный html код страницы можно увидеть следующую ошибку: 

<b>Fatal error</b>: Call to a member function getElementByPath() on a non-object in <b>/home/rassola/wemarus.ru/administrator/components/com_modules/models/module.php</b> on line <b>122</b><br />

 Причина этому скрывается в том что вы не правильно указали кодировку в фале настроек шаблона который находится /templates/ваш_шаблон/templateDetails.xml.

Открыв этот файл вы увидите в первой строке

 <?xml version="1.0" encoding="windows-1251"?>

 А сайт то у нас имеет кодировку в юникоде так что удаляем эту строчку вообще либо меняем на эту:

 <?xml version="1.0" encoding="utf-8"?>

Вот теперь все работает и на хосте который скорее всего под линуксом и на денвере который под виндоусом!

Комментарии  

 
0 #2 Administrator 27.09.2013 03:06
Цитирую Mike:
Спасибо, помогло!

Рад что помогло, обычно редко такое случается у людей, нго у меня вот случилось, и решил я все же описать про это чтоб потом люди не мучались если и у них настройки модуля будут тоже не видны.
Цитировать
 
 
0 #1 Mike 08.08.2013 13:07
Спасибо, помогло!
Цитировать
 

Добавить комментарий


Защитный код
Обновить

Поиск

Голосование

Что Вы думаете на счет битрикса?
 

Все материалы раздела